آسیب پذیری وردپرس در کدهای کوتاه بر 700000 سایت تاثیر می گذارد


پایگاه داده آسیب‌پذیری ملی دولت ایالات متحده (NVD) توصیه‌ای درباره افزونه Shortcodes Ultimate WordPress منتشر کرد و هشدار داد که حاوی یک آسیب‌پذیری Cross Site Request Forgery است.

Shortcodes Ultimate یک افزونه بسیار محبوب وردپرس است که بیش از 700000 نصب فعال دارد.

این آسیب‌پذیری بر نسخه‌های افزونه قدیمی‌تر از نسخه فعلی 5.12.2 تأثیر می‌گذارد.

آسیب پذیری جعل درخواست بین سایتی

جعل درخواست بین سایتی که معمولاً به آن CSRF می گویند، نوعی آسیب پذیری است که در بدترین حالت می تواند منجر به تصاحب کامل وب سایت شود.

این نوع آسیب‌پذیری‌ها معمولاً با هدف قرار دادن یک نقص در نرم‌افزار ایجاد می‌شوند که می‌تواند باعث تغییر شود، که می‌تواند منجر به عواقب ناخواسته شود.

یک حمله موفقیت آمیز عموماً به کاربری بستگی دارد، به عنوان مثال دارای امتیازات مدیریتی، کلیک کردن بر روی پیوند و افشای ناخواسته اطلاعاتی مانند کوکی جلسه که سپس می تواند برای جعل هویت آن شخص مورد استفاده قرار گیرد.

این نوع آسیب‌پذیری به مهندسی اجتماعی بستگی دارد، که کاربر نهایی را برای انجام یک عمل دستکاری می‌کند و سپس از آسیب‌پذیری افزونه بهره می‌برد.

طبق پروژه امنیتی برنامه وب باز (OWASP):

CSRF حمله ای است که قربانی را فریب می دهد تا یک درخواست مخرب ارسال کند.

این هویت و امتیازات قربانی را به ارث می برد تا یک عملکرد نامطلوب از طرف قربانی انجام دهد…

برای اکثر سایت‌ها، درخواست‌های مرورگر به طور خودکار شامل هر گونه اعتبار مرتبط با سایت، مانند کوکی جلسه کاربر، آدرس IP، اعتبار دامنه ویندوز و غیره می‌شود.

بنابراین، اگر کاربر در حال حاضر در سایت احراز هویت شده باشد، سایت هیچ راهی برای تمایز بین درخواست جعلی ارسال شده توسط قربانی و درخواست قانونی ارسال شده توسط قربانی نخواهد داشت.

پایگاه ملی آسیب پذیری (NVD)

پایگاه داده ملی آسیب پذیری تنها چند جزئیات در مورد این آسیب پذیری منتشر کرد. در حال حاضر هیچ تفکیک کاملی از خود آسیب پذیری وجود ندارد.

مشاوره NVD موارد زیر را منتشر کرد:

«آسیب‌پذیری Cross-Site Request Forgery (CSRF) در افزونه Shortcodes Ultimate <= 5.12.0 در وردپرس که منجر به تغییر تنظیمات از پیش تعیین شده افزونه می‌شود.»

تغییر لاگ رسمی Shortcodes Ultimate GitHub به همین ترتیب مبهم بود و به‌روزرسانی را برای رفع آسیب‌پذیری توصیف می‌کرد:

“### 5.12.1

**انتشار امنیتی**

این به روز رسانی یک آسیب پذیری امنیتی در تولید کننده کد کوتاه را برطرف می کند. با تشکر از دیو جان برای کشف آن.

در همین حال، گزارش تغییرات مخزن پلاگین وردپرس توضیح می دهد:

«رفع مشکل پیش‌تنظیم‌های Shortcode Generator، معرفی‌شده در به‌روزرسانی قبلی»

به نظر می رسد تغییرات بالا نام محقق امنیتی را غلط املایی می کند که به درستی Dave Jong، مدیر ارشد فناوری Patchstack، شخصی که به کشف و گزارش این آسیب پذیری اعتبار دارد، نوشته شده است.

دوره اقدام توصیه شده

ناشران وردپرس که در حال حاضر از افزونه Shortcodes استفاده می کنند باید به آخرین نسخه به روز رسانی کنند که در زمان نگارش در حال حاضر نسخه 5.12.2 است.

استناد

مشاوره پایگاه داده ملی آسیب پذیری را بخوانید

جزئیات CVE-2022-38086

اطلاعیه Patchstack را بخوانید

افزونه وردپرس Shortcodes Ultimate <= 5.12.0 – آسیب پذیری جعل درخواست بین سایتی (CSRF)

تصویر ویژه توسط Shutterstock/Cookie Studio





منبع